Algoritmos pseint

Clasificado en Otras materias

Escrito el en español con un tamaño de 1,54 KB

 
Proceso ejercicio3guia
//Leer 20 numeros e imprimir cuantos son +, - y cuantos son ceros
Dimension numero [20] //vector
//variables
positivos <- 0;
negativos <- 0;
ceros <- 0;
suma <- 0;
resta <- 0;
x <- 1
mientras (x <=20) Hacer
escribir "Ingrese Numero :";
leer numero[x]
x <- x+1
FinMientras
escribir ""
escribir " ** Numeros positivos ** ";
positivos <- numero [1];
PARA J <- 1 hasta 20 con paso 1 Hacer
si (numero [j] > 0) Entonces
suma <- suma+1;
FinSi
finpara
escribir "Cantidad de Numeros Positivos :",suma;
escribir ""
escribir " ** Numeros Negativos ** ";
positivos <- numero [1];
PARA J <- 1 hasta 20 con paso 1 Hacer
si (numero [j] < 0) Entonces
resta <- resta+1 ;
FinSi
finpara
escribir "Cantidad de Numeros Negativos :",resta;
escribir ""
escribir " ** Ceros ** ";
positivos <- numero [1];
PARA J <- 1 hasta 20 con paso 1 Hacer
si (numero [j] = 0) Entonces
ceros <- ceros+1 ;
FinSi
finpara
escribir "Cantidad de Ceros :",ceros;
FinProceso